You are not logged in.

Announcement

*** NOTICE: forum.openstreetmap.org is being retired. Please request a category for your community in the new ones as soon as possible using this process, which will allow you to propose your community moderators.
Please create new topics on the new site at community.openstreetmap.org. We expect the migration of data will take a few weeks, you can follow its progress here.***

#1 2021-05-17 17:04:15

WillyAS
Member
Registered: 2021-05-17
Posts: 3

OSMAnd does not avoid motorways

Probably doing something wrong, but I can't find out what. I try to route with avoiding motorways (highways), so I tick "Avoid motorways" and it shows up in the directions window. Then I set the destination and say .. go smile. But to my astonishment it keeps sending me over the motorways, also when I use the Brouter engine.
But using the same BRouter engine in QMapShack gives a perfect route, avoiding all motorways. So it is possible, but h ow ... ?

Offline

#2 2021-05-17 19:12:21

Sandal man
Member
From: Benissa
Registered: 2016-09-23
Posts: 313

Re: OSMAnd does not avoid motorways

Are you sure you are using the same profile for the setting and the navigation?
Foot, car or else?


Passionate hiker on the Costa Blanca, Spain.

Offline

#3 2021-05-18 06:06:19

WillyAS
Member
Registered: 2021-05-17
Posts: 3

Re: OSMAnd does not avoid motorways

Well that was something I was thinking the cause was, but no. What I do is: Directions > Options > Choose profile > Options > Avoid roads > Check "No motorways". Then I select the destination and get still a route that is nearly completely over motorways, but on screen the little box with "No motorway" crossed  out.
I use a profile thats using the BRouter engine (car-eco), but also the standard car profile (using OSM routing) behaves the same. In both cases there is no difference between the routes, whether I try to avoid motorways or not.

So I am at a loss here ..

Last edited by WillyAS (2021-05-18 07:55:49)

Offline

#4 2021-05-18 13:09:16

WillyAS
Member
Registered: 2021-05-17
Posts: 3

Re: OSMAnd does not avoid motorways

Apologies neutral I made a mistake. It is only with the BRouter engine that the motorways are coming up, even when given to avoid them. I was forgotten I set the "navigation type" for the standard car profile to BRouter.
When setting the navigation type to "OSMAnd routing" routing works with motorways. When saying "no motorways" I didn't have the patience to wait until it was ready; it took more then 5 minutes for a route of some 90 km ! But for a route of some 30 km "OSMAnd routing" with "no motorways" worked.

So what stays as my problem that when using BRouter as navigation type, I cannot route outside motorways.

(Using OSMAnd routing takes way too long.)

Offline

Board footer

Powered by FluxBB