You are not logged in.

#1 2021-01-28 21:02:24

Ethion150
Member
Registered: 2021-01-28
Posts: 5

Trouble removing a label

I'm trying to make a custom map of the Kanto region in Japan. I'm using Mkgmap with the Kanto subregion extract from Geofabrik.  When the map renders I get the this odd "ah4ht" label on what I think is residential streets or unnamed roads. I'm not sure how to make this particular label disappear. Anyone know?

Thanks!!

Capture.JPG

Offline

#2 2021-01-28 22:21:39

GerdP
Member
Registered: 2015-12-18
Posts: 1,505

Re: Trouble removing a label

Please post a link to the OSM data of one of the roads.

Offline

#3 2021-01-28 23:18:40

Ethion150
Member
Registered: 2021-01-28
Posts: 5

Offline

#4 2021-01-28 23:49:06

RicoElectrico
Moderator
From: Trójmiasto
Registered: 2012-07-01
Posts: 1,753

Re: Trouble removing a label

I tried to search for POI names depicted... I may be totally mistaken, but these transliterated names don't seem Japanese. It's as if Kanji ideograms were interpreted as Chinese (there is "xie" and "zh" in Chinese transliterations, but not Japanese ones).

Offline

#5 2021-01-29 00:43:47

Ethion150
Member
Registered: 2021-01-28
Posts: 5

Re: Trouble removing a label

Here is a link to the area:

https://www.openstreetmap.org/query?lat … =139.74047

Nothing on that particular street except: Unclassified Road #126236807


To Rico's point, there is a lot of incorrect transliteration going on here. I'm not sure if that is something GeoFabrik does or what. I didn't run anything on the extract file prior to processing it with splitter and mkgmap. That red cross POI in the picture, if it was converted to Romanji correctly, it should be something along the lines of "shirominamifukushiiryoukyoukai ootaashika" which a google search turns up to be a dentist office.

https://www.google.com/maps/place/%E5%A … 139.737732

Offline

#6 2021-01-29 14:12:30

RicoElectrico
Moderator
From: Trójmiasto
Registered: 2012-07-01
Posts: 1,753

Re: Trouble removing a label

Ethion150 wrote:

I'm not sure if that is something GeoFabrik does or what

No, Geofabrik just cuts OSM data, they do no processing. (Except shapefiles which are a small selection of OSM data in thematic layers).

Can you post configs for (I presume) mkgmap so somebody could replicate?

Offline

#7 2021-01-29 14:36:17

GerdP
Member
Registered: 2015-12-18
Posts: 1,505

Re: Trouble removing a label

Might be a style that adds labels to unnamed roads in combination with a missing/wrong --code-page setting

Offline

#8 2021-01-29 15:31:38

Ethion150
Member
Registered: 2021-01-28
Posts: 5

Re: Trouble removing a label

mkgmap commands:

java -Xmx20G -jar mkgmap.jar --max-jobs --gmapsupp --nsis --output-dir=./kanto --mapname=90019001 --country-name="Japan" --family-id=42 --family-name="Japan Family" --series-name="Japan Series" --area-name="Japan" --country-abbr="JP" --style-file=./default --precomp-sea=./sea-latest.zip --generate-sea --route --drive-on=left --process-destination --process-exits --index --bounds=./bounds-latest.zip --remove-ovm-work-files --name-tag-list=name:en,brand,name:ja_rm,name:ja-Latn,name:ja_kana,int_name,name --transparent --add-pois-to-areas --verbose --input-file=./mapnik.txt -c ./kanto_split/template.args

The style files I edited were the default style in the examples folder of mkgmap, and the edits were mostly commenting out POIs I didn't want on the map. https://gist.github.com/stevengorrell/b … b78445d9d9

Last edited by Ethion150 (2021-01-29 15:43:54)

Offline

#9 2021-01-29 17:34:30

GerdP
Member
Registered: 2015-12-18
Posts: 1,505

Re: Trouble removing a label

Did you try to add --code-page=65001 (or --unicode) ?

Offline

#10 2021-01-29 19:17:50

Ethion150
Member
Registered: 2021-01-28
Posts: 5

Re: Trouble removing a label

Wow! Thanks for that. Adding --code-page=65001 has made a world of difference. big_smile

Capture3.JPG

Offline

#11 2021-01-30 09:41:50

GerdP
Member
Registered: 2015-12-18
Posts: 1,505

Re: Trouble removing a label

To be honest, I have no idea why it helped. I am not able to reproduce the strange labels with your original options, so I guess you looked at cached results. Compare the two screen shots, they are very different, so I assume the map in the first screen shot was created with a different style.

Offline

Board footer

Powered by FluxBB