You are not logged in.

#1 2020-08-08 00:50:04

Petsamo
Member
Registered: 2016-06-05
Posts: 19

JRELoadError

Installed JOSM for Mac and it gave the error above. How to solve it?

Offline

#2 2020-08-28 01:14:19

mbirth
New Member
Registered: 2019-06-24
Posts: 1

Re: JRELoadError

Same here. From what I could gather, the launcher is supposed to check for a supported Java version and it seems that it only deems Oracle Java as "valid" and doesn't work with OpenJDK.

So find an old installer for Oracle Java 8, e.g. from here: https://github.com/frekele/oracle-java/releases and after installing it, JOSM should work. Of course, this isn't a long-term solution as Java 8 is quite old already.

Offline

Board footer

Powered by FluxBB