OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2019-01-21 15:27:51

GerdP
Member
Registered: 2015-12-18
Posts: 632

Falsche Poly files bei Geofabrik?

Moin!

Bei der Geofabrik gibt es seit einiger Zeit *.poly files, die in JOSM (mit poly plugin) nicht wie erwartet angezeigt werden.
Beispiel: Bremen http://download.geofabrik.de/europe/germany/bremen.poly

Ab Zeile 85 findet man (Stand heute):

   8.517022E+00   5.347260E+01
   8.514411E+00   5.347464E+01
   8.509653E+00   5.347469E+01
END
END
2
   8.615320E+00   5.319451E+01
   8.611878E+00   5.319620E+01
   8.613360E+00   5.319747E+01 

Nach meinem Verständnis sollte da nur ein End stehen.

Interessant dabei: In JOSM wird der Teil für Bremen angezeigt, in osmosis wird der Teil für Bremerhaven verwendet. Ich frage mich, warum das sonst niemand stört?

Edit: Ergänzung: osmconvert stört sich gar nicht dran und gibt das gleiche aus wie mit nur einem END. Stellt sich mir die Frage, was man wo korrigieren sollte.
Edit2: Sowohl JOSM als auch osmosis 0.4.5 hören nach dem ersten Block auf, der enthält Bremerhaven.

Last edited by GerdP (2019-01-21 16:26:34)

Offline

#2 2019-01-21 19:49:59

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 15,691
Website

Re: Falsche Poly files bei Geofabrik?

GerdP wrote:

Nach meinem Verständnis sollte da nur ein End stehen.

Stimmt. Poly-Files bestehen aus Blöcken von <block#> ... END pro Ring und nur am Ende steht noch ein weiteres END.

Gruss
walter

Last edited by wambacher (2019-01-21 19:50:26)

Offline

#3 2019-01-21 20:03:56

woodpeck
Member
Registered: 2009-12-02
Posts: 835

Re: Falsche Poly files bei Geofabrik?

Ich hab eben geschaut. Das Programm, das diese Poly-Files ausrechnet, kann einfach keine Multipolygone. Offenbar hat vor Dir noch niemand genau auf das bremen.poly geschaut! Zum Ausschneiden selbst werdern diese Poly-Files auf dem Server nicht benutzt, stattdessen kommen Files zur Anwendung, die in Richtung der Aussengrenze des umgebenden Ausschnitts grosszügig ausladen - z.B. geht das Baden-Württemberg-Polygon geradewegs nach Westen ins Elsass, dann gerade südlich, dann gerade zurück, anstatt mühsam den Rhein zu verfolgen - denn das Baden-Württemberg-File wird aus dem Deutschland-File ausgeschnitten, und dort wurde der Rhein ja schon sauber begrenzt, und im Elsass sind ja dann gar keine Daten mehr. Das spart Zeit beim Ausschneiden. Und das Programm, das nun (nur informationshalber für die Nutzer) das Deutschland-Polygon mit dem Baden-Württemberg-Polygon verschneidet, das hat einen Fehler bei Multipolygonen.

Die Reparatur wird mich fünf Minuten kosten, und dann noch eine halbe Stunde, um das Asbach-Uralt-Program mit dem aktuellen GEOS zu kompilieren wink

Bye
Frederik

Offline

#4 2019-01-21 20:15:22

GerdP
Member
Registered: 2015-12-18
Posts: 632

Re: Falsche Poly files bei Geofabrik?

Danke, ich habe sonst auch noch kein weiteres falsches *.poly gefunden.
Ich arbeite auch an einem Patch für das JOSM poly plugin. Ob ich jetzt das falsche END ignorieren oder eine Fehlermeldung ausspucken soll,  ist mir noch nicht ganz klar.

Offline

#5 2019-01-22 07:02:21

GerdP
Member
Registered: 2015-12-18
Posts: 632

Re: Falsche Poly files bei Geofabrik?

Noch eine Frage an die Experten: Kann jemand etwas mit dem Beispiel im Wiki anfangen? Das soll wohl ein Beispiel für ein MP mit Inner sein, aber es ist irgendetwas anderes.

Offline

#6 2019-01-22 11:54:08

woodpeck
Member
Registered: 2009-12-02
Posts: 835

Re: Falsche Poly files bei Geofabrik?

woodpeck wrote:

Die Reparatur wird mich fünf Minuten kosten, und dann noch eine halbe Stunde, um das Asbach-Uralt-Program mit dem aktuellen GEOS zu kompilieren wink

Ist jetzt auf dem Server repariert.

Bye
Frederik

Offline

Board footer

Powered by FluxBB