You are not logged in.

#1 2015-04-01 22:02:08

kh53
Member
Registered: 2015-04-01
Posts: 1

osm combiner error

Hello,

I would like to combine several tiles of maps but i always recieve the following error when i push on start to become to entire map. Could somebody tell me what i'm doing not correct.

Time started: Wed Apr 01 22:51:21 CEST 2015
Exception in thread "main" java.lang.IndexOutOfBoundsException: Index: 12416, Size: 1714
    at java.util.ArrayList.rangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at uk.me.parabola.imgfmt.app.lbl.LBLFileReader.readPoiInfo(LBLFileReader.java:413)
    at uk.me.parabola.imgfmt.app.lbl.LBLFileReader.<init>(LBLFileReader.java:74)
    at uk.me.parabola.mkgmap.combiners.FileInfo.lblInfo(FileInfo.java:326)
    at uk.me.parabola.mkgmap.combiners.FileInfo.lblInfo(FileInfo.java:313)
    at uk.me.parabola.mkgmap.combiners.FileInfo.imgInfo(FileInfo.java:259)
    at uk.me.parabola.mkgmap.combiners.FileInfo.getFileInfo(FileInfo.java:152)
    at uk.me.parabola.mkgmap.main.Main.endOptions(Main.java:525)
    at uk.me.parabola.mkgmap.CommandArgsReader.readArgs(CommandArgsReader.java:128)
    at uk.me.parabola.mkgmap.main.Main.main(Main.java:119)
Er is een fout opgetreden. Controleer onderstaande log.

thanks

Offline

#2 2015-04-02 09:32:30

SomeoneElse
Member
Registered: 2010-10-13
Posts: 1,213

Re: osm combiner error

Your error message includes "mkgmap" so presumably you're asking about creating maps for Garmin handhelds.  I'd ask over in the forum for that http://forum.openstreetmap.org/viewforum.php?id=26 , but I'd also try adding a bit more information - what exactly (full command lines) are you doing before the error occurs?

Offline

#3 2015-04-03 17:59:23

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Which mapsets are your trying to combine exactly?
It needs to be from the same date from garmin.openstreetmap.nl otherwise you would get problems when those mapsets are compiled with different versions of mkgmap, different planet extracts etc. Also you need plenty of memory to do this with big mapsets.

Offline

#4 2015-04-06 13:13:43

whoolwerf
Member
Registered: 2015-04-06
Posts: 4

Re: osm combiner error

Hmm, same error here. Just downloaded 4 MAPS from garmin.openstreetmap.org: Netherlands, Germany, Belgium and Luxembourg. Downloaded all maps in parallel, so definitely the same date, unless of course maps on the server are not aligned....

Offline

#5 2015-04-06 17:20:13

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Ok, thanks for reporting, maybe the mkgmap version of the maps are not compatible anymore with the mkgmap version that is provided with osm combiner. Osm combiner is not longer maintained by Javawa so we have to find another way to fix this. You can try to download a more recent mkgmap.jar from mkgmap to see if the problem is fixed, http://www.mkgmap.org.uk/download/mkgmap.html.

Offline

#6 2015-04-07 11:27:50

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Just tested two mapsets (Belgium and Luxemburg, osm_generic_new_tiles.zip) and no errors occur.
Did you combine the tiles.zip files? Which map (generic, generic new or openfietsmap?).

Offline

#7 2015-04-08 14:03:18

whoolwerf
Member
Registered: 2015-04-06
Posts: 4

Re: osm combiner error

I downloaded and tried to combine the IMG-files. I'll try with the tiles. I'll also try your other suggestion (downloading the newer version of mkgmap).

Thanks for your support.

btw: If OSM combiner is not maintained/supported anymore, do you have any other suggestions for merging maps?

Offline

#8 2015-04-08 17:43:49

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

You can't use the custom map selection of garmin.openstreetmap.nl for a bigger area?

Offline

#9 2015-04-10 10:17:15

whoolwerf
Member
Registered: 2015-04-06
Posts: 4

Re: osm combiner error

Tried the tiles.zip, instead of downloading the img's. Didn't work (same error). Updated the mkgmap in OSM by simply replacing the jar, that seems to have solved the issue. I have a merged IMG now. Will check this weekend if it actually works, but at least I got no errors or warnings.

Btw: Yes, I can use the map selection feature of garmin.osm, but: it's easier to just download the countries I want, instead of selecting an area on the map (it's fidly and I'm bound to be missing some border piece or another of a country whenever I'm in that country). Also, downloading pre-compiled maps lessens the load on the OSM servers. But I have tested it, and it does work, so it's a viable alternative.

Would be great if garmin.osm also had other precompiled mapsets, for example for full europe, west-europe and east-europe.

Thanks again for your help.

Offline

#10 2015-04-10 12:24:34

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Thanks for testing whoolwerf, I'll ask Javawa if he could update the osm combiner tool with a recent mkgmap version.
If anyone else is willling to help updating and compiling the source file, it can be found here:
http://osm.pleiades.uni-wuppertal.de/op … Source.zip

Offline

#11 2015-04-12 09:23:23

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

@kh53 and whoolwerf
I uploaded a new version of OSM Combiner (thanks Javawa!)
http://osm.pleiades.uni-wuppertal.de/op … _Combiner/

Please test it and report your findings here.

Offline

#12 2015-04-13 13:50:52

whoolwerf
Member
Registered: 2015-04-06
Posts: 4

Re: osm combiner error

downloaded and installed the new version (fully uninstalled the old version first, to be sure) and it works just fine now.

Offline

#13 2015-12-08 14:38:53

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

It seems the current version of OSM Combiner (1.7) cannot deal with the latest generated img's anymore.
If the combining tool fails, please update the mkgmap version in the install directory with mkgmap-r3650 or later (http://www.mkgmap.org.uk/download/mkgmap.html).

Offline

#14 2015-12-11 00:31:11

JaVaWa
Member
Registered: 2010-11-15
Posts: 137
Website

Re: osm combiner error

A new version is on its way to ligfietser...

Offline

#15 2015-12-11 12:16:40

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Thanks Javawa! The latest version 1.8 is available for download now.

Last edited by ligfietser (2015-12-11 19:34:23)

Offline

#16 2016-03-22 12:31:35

DeEenzameFietser
Member
Registered: 2016-03-22
Posts: 3

Re: osm combiner error

Hello,
Unfortunately the new OSM Combiner 1.8 did not solve the problem for me.
I dowloaded a fresh set of osm_generic_tiles.zip files for the Netherlands, Belgium and France and tried to combine them with OSM combiner 1.8 but consistently get an error message (see below). All steps up to "Start" work, the final step fails and gives the error message.
I use MacOS 10.11.3 with the latest Java installed and allocated 5gb of memory to Java, disk space is plenty.

What am I doing wrong?

Thank you!

--- Error message:

Exception in thread "main" java.lang.UnsupportedClassVersionError: uk/me/parabola/mkgmap/main/Main : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Er is een fout opgetreden. Controleer onderstaande log.

Offline

#17 2016-03-22 17:37:21

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Thanks for reporting Eenzame, maybe OSM Combiner has an out-of-date version of mkgmap and needs an upgrade, I'll check it out.

Offline

#18 2016-03-22 18:55:22

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Eenzame Fietser, which version of Java are you using?
Please note that Java 6 or lower is not supported anymore.

Offline

#19 2016-03-22 23:05:58

DeEenzameFietser
Member
Registered: 2016-03-22
Posts: 3

Re: osm combiner error

I just installed Java 8. But what I did find out in the mean time is that the MacOS keeps loading version 6 as well. Probably that is not what OSM Combiner likes.
Problem is that I still need Java 6 for Photoshop to function (really? yes, really! Adobe and Apple are not good friends I guess). But even aside from that, I could not get Java 6 removed. Thursday I have a day off and will experiment some more. Unless someone here has a better understanding of what is going on.
I'll keep you posted.

Offline

#20 2016-03-24 16:36:41

DeEenzameFietser
Member
Registered: 2016-03-22
Posts: 3

Re: osm combiner error

Apparently installing Java 8 on a Mac that has Java 6 installed does not automatically replace 6 with 8.
The solution is to open terminal and run:
export PATH=/Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin:$PATH

Then log out and back in. OSM Combiner is then directed to use Java 8. And the good thing is that Photoshop runs simultaneously using Java 6, no need to switch back to Java 6 manually.
NOTE: If you need Java 6 on a Mac, please make sure you use the Java 6 from the Apple site. I understand that that is a version of Java with all internet connection possibilities disabled for security reasons, making it perfectly safe to use.

Happy mapmaking!

Offline

#21 2017-01-15 11:36:53

De Kock
Member
Registered: 2017-01-15
Posts: 7

Re: osm combiner error

I have got also a problem with Combiner. I,ve got version 1.8 and installed Java 8. Downloaded a few maps and I like to build Benelux, North Europe and South Europe.
Started with the smalles amount of data, Benelux. But still get these error messages.
plVSSCkhmbMcmg3QRmVI2jtc1BaoA6bHcpjsdj4TwDOH21ec9WkVHBsr7M0KDx7wqvuU4uy8WwmcYrBnGt_F7CS7QQqBbhAhhgQx159jd3WzAEZv4mYmaNOsclvL0NNSADuMFPg0ceGlvi1wsF_mZImupRNvxg_j6fqr5W7tUu52GkSn4PXsLv2ta_Cp3ndqrd-yZy7xExcaP9XxHS5MLjSizqDOhzZveHGeSsHnTlBCL_ga9pLRxnffA3tT_4lX-ZA1U5bbN60L54rujb4EPKJdMMl4NJtkfwbL7NhyX-oa_NcccFce35-_CzKDKJTm8l5BEo8RX8BBjnuMuf0SsdfCZ5x2UYLAU1flmDbZCC4Ik3WwRh1wPpXrBZPUFAROlfboq-h80fsfUW1FVUMxJ3Y5I2xYrpAeVfAo1KmXyGdR0KwdR4TXy9AcbTOghvUokCWsW9_yPFz_M75kEDzqxVWOAE87G2ojR39U9xZ5srWLkDDEEOYq838x6k9_cvKSNarswLJseOd7dWU_ABbp5h0fbLjrN5strTQp0JeVSKwawpx58zaROWCeWxzvR2PYPrJcoeOTRLYVASiVap-zssYTVmLwcuzrhkhJw0jzj-y2oGlIExz7t6RJ9es-bznv9ZHJhC-3qYsIJrh_g5TizdvrbDa3veP-7wryA4dKTg=w663-h489-no
These messages are different when I change some settings, such as the memory from Java in the rename field of Combiner.
What can I do to make it work?

Offline

#22 2017-01-15 12:29:00

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

I see an Out of Memory Error. How much memory does your computer have?
It also helps if you exclude the gmapsupp compilation.

Offline

#23 2017-01-15 12:44:50

De Kock
Member
Registered: 2017-01-15
Posts: 7

Re: osm combiner error

These are de specs of my computer.
tbtWm2af0zyyQpLLh95nnbizfFECMFA0ycC-YxrIwvcj-8R6PL_c2Plsfsp-5upSBuzsndANtXwj--z0qOwyazkPjcSM8b2iA4QMTStT3aJOufdE9twtoZZGWeYJqpv-BA_hY8W-i-cFNOcwf9rdvAXCk77amQrTyTfL5Bz16SWxF-o-V-VeSZ8eE_KXgccn-BDiUYpFnW-NxlZmnwp7pEVh36gb8bi2bARyAR-DxwKpfrLLjMpZ7SvFK2bgpfDAPvSQ9wTlBGoitoLVNO1mJHHYljRJ0jfUQ5_xVbCO3jx27k-5NqI871_mMGMFybp0-1F--ivm2MJZsluXTbsNBg_FqJd3Dg1Q11yD81wx2e079SfwD7MjHMpXrUJCuf_eZKbRANbr0mpaOsYnJxpZRerQJssyS6ytbuJWq1dCQ0qGDlFRlBeHWXhauggabKSLTKs_WQjWvlGgssb5TuZtZiRW1qkOGeeexaBgH5QufOOrP5s_Y6hMfja975PzBi0RLf2tN0cBaPLGLpIoZNmW81sWcV2wiwVzTm82AhhSdMheA8lgVx-CV5Nq4G7MNMbNXlgBzACHxrH2tNK9CXuLZQ5xt65WfcgugQPIz_PZ-_11JZtt620KFDtp6chszflGeWdi6jcj2BbgFl0_8ZZcpXsMzBbSo1pz4ust-s-NhQ=w679-h452-no
X87KVHQVSlPgDr2SotgwLwZ8BpbDAn79vUAmjLqXQpKBfUsmQ-7fm0zthBNYXN8LI8kBXC_paH2_Jj418FI5lEHE-NmIRiMvRfE0s_Fa6YnI1q5v2GflZUGHpge3rVEtgf6_Vldy31zDVwBZwzidnjZREcpbQBZed80IR_gwGOly9AAHoVCjePRjM_rl4v_zyk0syQH60Qu_zyk4vcsAmlnXZeQBYru7TjhFsVh3dHXK_b1cF23yoeaxzAbo-gXbWQHkyrQRmJL-uVvtTaD5GlxGJu_nrhqGwgBnVTctc-AAuAio_Y9-mo24kVqh-08JT95KmY-1Qy7746QH1bBK6mUtA7opjlObf1eEil1ChmmGDeaHxXoq1cV2UZ7CkKRCU8yLVFy4YkJWAtNah2kw2dj_83JUYGYJBTvoKNxPwSBCEtfwoCjvfyVnvwylCZGqhCMHj7KvnM-q_l8JJ5edKtD7ZLO1nicI0VOFgKt2M8gG7Dw_GP98iLaUau1fWCRjzDf8MCyZFwBKrAGA5S9w7HWFvPWvEBpiZcbX9PAR1_TVZGicH23MNE6EhvJejLSowhur4_I78AyhJLO39a1OI97-M2yIyTz4NoohqIZHwXrxEGnDje5RPnwR57nEbib6RQeNp7cekr4vrJbDQfkC282tQ7VNbi8nEbkVoNSoRA=w690-h559-no
I am not that good with computers, but my endurance is endless. I,m am a very curios person and I want to now en learn it all.
And it is practical to use only the maps you need in your device, so I want to split Europe in different sections.
So,, do I have a hardware problem ore software?

Offline

#24 2017-01-15 13:03:03

ligfietser
Moderator
Registered: 2008-10-09
Posts: 5,127
Website

Re: osm combiner error

Your pc seems ok to do the job. It should handle the Benelux fine with 2000 MB. For whole Europe you need more, 4000MB.
Try it first without the gmapsupp option. You can always send tiles with Basecamp to your gps and the size of a gmapsupp file should not exceed 4 gb anyway. I dont know why you want to use OSM combiner to make gmapsupp's. It is mainly intended to install maps on your computer.

Offline

#25 2017-01-15 16:17:49

De Kock
Member
Registered: 2017-01-15
Posts: 7

Re: osm combiner error

I dont know why you want to use OSM combiner to make gmapsupp's.

I don,t, I don,t activate this option. Intention is indeed to make maps for the computer and later send the maps I need to the GPS.
I use by the download the OSM_generic_tiles files and did that all together, so the overlap maps should have the same number.
I,ll keep on trying, but still getting these error reports.

Offline

Board footer

Powered by FluxBB