You are not logged in.

#1 2014-09-17 23:25:03

gregcrago
Member
Registered: 2014-05-09
Posts: 37

STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

Awhile ago, UNSURFACED roads had a DASHED Linetype, but currently they look like SURFACED roads. Can you change it back to DASHED LINES, so us mappers can see ERRORS quickly whitout having to start ID editor.

Example

https://www.openstreetmap.org/way/8762936

Offline

#2 2014-09-23 11:45:03

XAN_ua
Member
Registered: 2012-10-20
Posts: 603

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

They are still dashed, if they taged with highway=track. If they taged with other highway, they will look like that highway tag.
And it isn't always an error: for example, this is how one highway=trunk used to look back in mid 00s, before reconstruction big_smile

Offline

#3 2014-10-16 19:38:28

gregcrago
Member
Registered: 2014-05-09
Posts: 37

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

Why can't HIGHWAY=RESIDENTIAL, SURFACE=UNPAVED show as a DASHED LINETYPE?

It is STILL DIRT and should be indicated as such.

I do not want to start changing all the dirt roads around my area to TRACK just to see DASHED LINES on the OSM STANDARD MAP.

Offline

#4 2014-10-16 19:54:49

DaveEMan
Member
Registered: 2014-07-15
Posts: 38

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

That sounds like a rendering problem and from everything I have read you shouldn't tag for the renderer. If you change it to track it could affect routeing. The Wiki lists track as "Roads for agricultural or forestry uses etc, often rough with unpaved/unsealed surfaces, that can be used only by off-road vehicles (4WD, tractors, ATVs , …) ." I use Openfieltsmap Lite and OSM generic routable new and they both show unpaved roads.

Offline

#5 2014-10-17 15:07:44

XAN_ua
Member
Registered: 2012-10-20
Posts: 603

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

gregcrago wrote:

Why can't HIGHWAY=RESIDENTIAL, SURFACE=UNPAVED show as a DASHED LINETYPE?

It is STILL DIRT and should be indicated as such.

The correct question is "Why can't HIGHWAY=RESIDENTIAL, SURFACE=UNPAVED show as a DASHED LINETYPE in Mapnik render?" Because there some renders that do show unpaved surfaces upon residential, unclassified and etc. roads, like UniRS render for OsmAnd Android app:
Screenshot_2014_10_17_16_49_18.png
(Compare to mapnik version)

The last time I checked, mapnik authors stated, that there is no way in current version to effectively draw lines that depends on many tags instead of one... So implementing acess=* on higways=* was already some kind of high-level magic. There also promises that those pats of codes will be rewritten eventually, so mapnik will be able to render any number of tags in one line, and everyone will be happy forever after.

gregcrago wrote:

I do not want to start changing all the dirt roads around my area to TRACK just to see DASHED LINES on the OSM STANDARD MAP.

Yes, that would be a stupid thing to do, 'cause "Don't tag for the renderer"

Last edited by XAN_ua (2014-10-17 15:10:43)

Offline

#6 2015-01-30 07:01:28

gregcrago
Member
Registered: 2014-05-09
Posts: 37

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

I am using Openstreetmap.org and using STANDARD LAYER and UNSURFACED roads are suppose to be DASHED LINES (according to the MAP KEY), but they are being drawn SOLID and look like PAVED roads.

How do I get UNSURFACED roads to look like DASHED lines, like the MAP KEY defines.

Greg

Offline

#7 2015-01-30 14:39:14

SomeoneElse
Member
Registered: 2010-10-13
Posts: 1,515

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

Oddly, it appears that the map key for the "standard" layer (which I think is https://github.com/openstreetmap/openst … ig/key.yml is incorrect).  That contains entries for both "unsurfaced" (which I've not encountered before) and "byway" (which definitely isn't rendered).

I've created an issue at the website: https://github.com/openstreetmap/openst … issues/882 - keep an eye on that to see progress (arguably the "bug" is that the _process_ of updating the openstreetmap-carto style doesn't include a step to update the map key - so that bug may get closed and linked to one in a different repository).

Note that there is already an issue in the openstreetmap-carto repository that says "we ought to render unpaved roads differently somehow":

https://github.com/gravitystorm/openstr … issues/110

Just repeating that statement won't make it happen because pretty much everyone agrees that in principle it's a good idea - the problem is how to do it in a way that doesn't confuse someone reading the map.  A number of the suggestions (such as dotted casing) clash with existing map features.

There may, of course, already be map renderings that render non-paved roads.

Offline

#8 2015-04-04 20:26:37

gregcrago
Member
Registered: 2014-05-09
Posts: 37

Re: STANDARD Layer in OSM not showing UNPAVED Linetypes anymore

SERVICE ROADS that are UNPAVED show up as DASHED LINE using STANDARD LAYER in OSM.

But HIGHWAY=RESIDENTIAL, SURFACE=UNPAVED still have solid linetypes. Why do Service Roads look 'correct' (dashed lines), but Residential Roads are still 'incorrect' (solid lines)?

Offline

Board footer

Powered by FluxBB