You are not logged in.

#1 2012-04-15 14:02:42

Pimousse
Member
Registered: 2012-04-15
Posts: 5

Potlatch2 : no display

Hi,

Few weeks ago, the openstreetmap server has changed and the map was in read-only for some time.

Since then, when I try to edit it, Potlatch2 seems to start correctly but then no map appeart, I only have the tools on the left hand side.

I use linux, firefox, and have the latest version of flashplugin installed (11.2.202).

Offline

#2 2012-04-16 02:27:17

MikeN
Member
Registered: 2009-09-03
Posts: 326

Re: Potlatch2 : no display

I see this also - with both Chrome and Firefox.   (At first I thought it was related to the read-only map, but it persists)

Offline

#3 2012-05-01 21:01:45

osmbingo
Member
Registered: 2012-05-01
Posts: 1

Re: Potlatch2 : no display

Same here, Potlatch2 just doesn't work (but Potlatch1 works fine). Firefox on Windows, latest Flash version.

Last edited by osmbingo (2012-05-01 21:02:36)

Offline

#4 2012-05-10 16:00:59

Pimousse
Member
Registered: 2012-04-15
Posts: 5

Re: Potlatch2 : no display

Potlatch2 works for me via the openmapquest website. So it does not seem to come from P2, but rather from OSM.

Offline

#5 2012-05-11 12:29:31

MikeN
Member
Registered: 2009-09-03
Posts: 326

Re: Potlatch2 : no display

> Potlatch2 works for me via the openmapquest website

  Curious - I see this also; it works for me with openmapquest, but not from OSM.

Offline

#6 2012-05-28 23:18:02

Hugues F
Member
Registered: 2012-04-09
Posts: 1

Re: Potlatch2 : no display

I have the same problem: try "private browsing", it works for me.
(Tools/Start Private Browsing)

Offline

#7 2012-05-30 06:19:00

Pimousse
Member
Registered: 2012-04-15
Posts: 5

Re: Potlatch2 : no display

It does not work for me.

Offline

#8 2012-06-12 23:17:16

Richard
Member
From: Charlbury, UK
Registered: 2007-04-24
Posts: 415
Website

Re: Potlatch2 : no display

Hmmmm. Could you try this?

1. Find the location of your Flash SharedObject files (like cookies). This will help for Mac and Windows; on Linux I think they're under ~/.macromedia/Flash_Player/ .

2. Within this, find where your OpenStreetMap shared objects are. On my machine, they're in #SharedObjects/PC7SMH2H/www.openstreetmap.org.

3. You should see a file called user_state.sol. Please e-mail that to me (richard@systemeD.net). Don't worry - it doesn't contain anything personally identifying, just your preferences (e.g. last imagery set).

4. If you like, you can then delete the file, and see if that makes Potlatch function any better!

Offline

#9 2012-06-13 02:01:08

MikeN
Member
Registered: 2009-09-03
Posts: 326

Re: Potlatch2 : no display

Ah HA - SUCCESS!   Here's what I did:

  I had previously disabled all local storage for privacy reasons - many sites like to use Flash to store secret cookies locally.


  Flash global settings -

http://www.macromedia.com/support/docum … ger06.html

Find www.openstreetmap.org .   Set it to always allow.

http://www.macromedia.com/support/docum … ger07.html


Find www.openstreetmap.org .   Uncheck "Never ask again", and give it 1 MB of storage.

Offline

#10 2012-06-13 11:37:45

Richard
Member
From: Charlbury, UK
Registered: 2007-04-24
Posts: 415
Website

Re: Potlatch2 : no display

Excellent. I suspect it's the latter one that's the issue - P2 doesn't need to use your camera or microphone. smile

Offline

Board footer

Powered by FluxBB