You are not logged in.

#1 2011-12-31 10:32:53

spod
Member
Registered: 2011-12-31
Posts: 5

JOSM 4667. How do I get it to import audio files correctly?

Just upgraded to JOSM version 4667 (from a fairly old version, probably) and I can't work out how to import audio files.

I'm using a VisionTac 900 GPS, which records audio. In the previous version of JOSM that I was using, I think I just imported the GPX file (having converted it with BT747) and JOSM would automatically import the audio tracks and put an audio marker along the track at each recording. Now JOSM doesn't seem to automatically import the audio, and none of the options in the Audio preferences panel seem to make it do what it used to do.

In the old version, I may have had some specific audio import settings set up (which presumably have been overwritten by the new version?), but I can't seem to get version 4667 to work as it did before.

Can anyone tell me what the magic options are to get it to work?!

Thanks.

Offline

#2 2011-12-31 11:25:12

stephan75
Member
Registered: 2008-05-28
Posts: 2,800

Re: JOSM 4667. How do I get it to import audio files correctly?

I have also trouble with sound files recorded on a tour outside via OSMTracker for Android.

It seems that soundfles have to be in WAV format, no other ... or a I wrong?

So what is your sound file format?

Offline

#3 2011-12-31 17:08:02

spod
Member
Registered: 2011-12-31
Posts: 5

Re: JOSM 4667. How do I get it to import audio files correctly?

The sound files are in WAV format.

Offline

#4 2012-01-10 11:31:15

spod
Member
Registered: 2011-12-31
Posts: 5

Re: JOSM 4667. How do I get it to import audio files correctly?

I now think that this problem is a bug that has been introduced into the core of JOSM at some point, as reported here:
http://josm.openstreetmap.de/ticket/6912
I went back to version 3377 of JOSM which seems to work correctly, as I remember it. That version of JOSM automatically imports the audio tracks (without having to do a separate 'Import audio' step), creates the playback markers and plays the audio correctly.

Offline

Board footer

Powered by FluxBB