OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2008-11-09 22:34:04

Yoda
Member
Registered: 2008-04-04
Posts: 19

The extraction of data not always working

I extract the area near my home so I can load it into the GPS to see what I missed but often it just fails with:

Warning: wildcards not supported in HTTP.
--08:21:50--  http://www.informationfreeway.org/api/0.5/*[bbox=145.2,-38.1,145.4,-37.9]
           => `vic.osm'
Resolving www.informationfreeway.org... 80.68.90.42
Connecting to www.informationfreeway.org|80.68.90.42|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://xapi.openstreetmap.org/api/0.5/* … 4,-37.9%5d [following]
Warning: wildcards not supported in HTTP.
--08:21:50--  http://xapi.openstreetmap.org/api/0.5/* … 4,-37.9%5d
           => `vic.osm'
Resolving xapi.openstreetmap.org... 128.40.58.202
Connecting to xapi.openstreetmap.org|128.40.58.202|:80... connected.
HTTP request sent, awaiting response... 501 Internal Server Error
08:22:17 ERROR 501: Internal Server Error.

I guess the server is having problems as the command is correct as it will work a couple of times a week.

The extract command I am using is:
wget -T 540 -O home.osm http://www.informationfreeway.org/api/0.5/*[bbox=145.2,-38.1,145.4,-37.9]


Is this normal behavior or am I doing something wrong?

Peter....

Offline

#2 2008-11-10 09:08:51

emj
Member
From: .se (59.3N17.99E) 0735969076
Registered: 2006-06-18
Posts: 949

Re: The extraction of data not always working

There is a problem with the exended api at this moment, you can check it out on the wiki Openstreetmap server status

They are trying to fix it, but 3 separate machines managed to break at the same time so I'm imagining it's not very fun at the moment.. :-)

Offline

#3 2008-11-22 00:37:20

Jochen Riehm
Member
Registered: 2008-11-21
Posts: 18

Re: The extraction of data not always working

Server status for osmxapi.hypercube.telascience.org is declared to be up and running, but produces 501 errors in my case too.

Offline

#4 2008-11-22 16:28:03

Skywave
Member
Registered: 2007-11-13
Posts: 91

Re: The extraction of data not always working

There are also the ROMA servers. But i don't know the URL for downloading data from them.

Offline

Board footer

Powered by FluxBB