You are not logged in.

#1 2008-06-11 14:37:52

wst
Member
Registered: 2008-06-11
Posts: 2

rendering problem / posible errors marked in map

Since end of may, there are posible errors marked in the OSM-map:

www.openstreetmap.org/?lat=47.03308&lon … yers=B00TT
(for example)

This should be avoided. New OSM users will think, most of OSM-Data is wrong.
Errors should only be reported in editing mode, but not in viewing mode.

Open for comments.
wst

Offline

#2 2008-06-12 09:47:01

OliverLondon
Member
Registered: 2008-04-04
Posts: 43

Re: rendering problem / posible errors marked in map

This is because you have the Maplint errors layer turned on.

Here is the same map showing just the Mapnik layer:

http://www.openstreetmap.org/?lat=47.03 … yers=B00FT

Offline

#3 2008-06-12 09:51:41

OliverLondon
Member
Registered: 2008-04-04
Posts: 43

Re: rendering problem / posible errors marked in map

While testing these links, I have found that the second one, which should show only Mapnik, is still opening Maplint as well.  This may be a server/website bug.  I am using IE6 whereas most developers (sensibly) use Firefox, so compatibility issues don't always get spotted.  Can you report which browser you're using?

I am a newbie, so if someone who knows where to report this (mailing list or trac) can advise us, that would great.

Oliver

Offline

#4 2008-06-12 15:46:49

wst
Member
Registered: 2008-06-11
Posts: 2

Re: rendering problem / posible errors marked in map

Hi Oliver,

thanks for taking care of the problem.

I'm browsing the web with Mozilla Firefox and with Firefox, the links are different.

Some more information on the problem: 3 weeks ago I used the same browser, the same URL and the same configuration at all - and the problem did not appear.

Perhaps the the format of the URL changed some days ago and my URL links now to the debug layer.

thanks for your comment.
wst.

Last edited by wst (2008-06-12 16:02:37)

Offline

#5 2008-06-12 16:56:33

the_winch
Member
Registered: 2008-02-24
Posts: 21

Re: rendering problem / posible errors marked in map

wst wrote:

Perhaps the the format of the URL changed some days ago and my URL links now to the debug layer.

At some point the cyclemap layer from http://www.gravitystorm.co.uk/osm/ was added which is possibly what broke your links.

Offline

#6 2008-06-13 08:39:59

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,269
Website

Re: rendering problem / posible errors marked in map

The layers ID in OL is dependent on the order in which the layers are created, so adding a layer in the middle changes the ID of the subsequent layers.


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

Board footer

Powered by FluxBB