You are not logged in.

Announcement

*** NOTICE: forum.openstreetmap.org is being retired. Please request a category for your community in the new ones as soon as possible using this process, which will allow you to propose your community moderators.
Please create new topics on the new site at community.openstreetmap.org. We expect the migration of data will take a few weeks, you can follow its progress here.***

#1 2022-08-12 14:36:12

Jonatan Krause
New Member
Registered: 2022-08-12
Posts: 1

Embedding uMap: showing layers

Hi,
I'm new to programming and am trying to experiment with embedding a UMAP map on a primitive html website. I created two layers that I want to be displayed by default. However, when I paste the umap code (from "Embed and share this map") in the html, the layers don't show on the page by default - instead, the layers are hidden, and have to be activated from the menu. This happened even though I enabled the "keep current visible layers" option.

Here's the code I get:

<iframe width="60%" height="300px" frameborder="0" allowfullscreen src="//umap.openstreetmap.fr/en/map/running-routes_796391?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false&datalayers=2365367%2C2365387"></iframe>

Hope it makes sense - and hope somebody can help.
Thanks in advance!

Offline

Board footer

Powered by FluxBB