You are not logged in.

#1 2021-03-13 14:52:49

derTTT
Member
Registered: 2015-01-24
Posts: 8

Osmarender-Probleme mit Multipolygonen

Hallo,

ich versuche mich aktuell mit dem Rendern von Karten. Ich verwende dazu Osmarender und Josm. Mit Josm speichere ich mir lokal eine Karte ab, bei der ich einige Dinge anpasse. In der Datei "osm-map-features-z17.xml" passe ich mir die Optik der Ausgabe an. Ziel ist es detailarme Karten zu erzeugen, die aber trotzdem einige Details enthalten, die in Übersichtskarten normalerweise nicht gezeigt werden. So lasse ich mir z.B. alle "highways - track" gleich anzeigen und auch alle Wanderwege gleich. Außerdem entferne ich parallellaufende Wanderwege, wie sie oft gemapt werden.

Nun habe ich das Problem, dass mir Multipolygone grundsätzlich nicht gerendert werden. Große Wald- und Wasserflächen, die mit Multipolygonen erstellt sind, werden nicht angezeigt. Wenn ich mir versuchtsweise eine kleine Wald-Fläche anlege wird mir diese gerendert, sobald ich diese als Multipolygon deklariere, nicht mehr! Die Richtung spielt dabei keine Rolle und auch ein einfaches Multipolygon mit 4 Punkten ohne weitere Innenflächen wird nicht gerendert!

Habe ich eine fehlerhafte Version der Dateien (aktuell gibt es ja nichts neueres oder)? Gibt es sinnvolle neuere Alternativen zu Osmarender, mit denen ich die Datei zunächst in Josm anpassen kann und anschließend nach meinen Vorstellungen in eine .svg rendern kann?

Vielen Dank für jedwede Unterstützung
Tim

Offline

#2 2021-03-15 21:03:17

stephan75
Member
Registered: 2008-05-28
Posts: 2,882

Re: Osmarender-Probleme mit Multipolygonen

Hmmm, welche Alternativen laut der Wiki-Seite

https://wiki.openstreetmap.org/wiki/SVG

hast du schon ausprobiert?

Offline

#3 2021-03-16 19:41:26

derTTT
Member
Registered: 2015-01-24
Posts: 8

Re: Osmarender-Probleme mit Multipolygonen

Maperitive habe ich ausprobiert. Erzeugt bei mir sehr störende Fehler. Mapnik kommt aufgrund der schwer zu nutzenden svg-Files nicht in Frage. Einige andere dort erwähnte Tools bieten mir nicht die Möglichkeit, die Rohdaten zuvor zu bearbeiten...

Aber es sieht so aus, als hätte ich letzte Nacht mit qualifizierter Hilfe Osmarender/orp unter Perl zum laufen gebracht. Ich würde das auch im Wiederholungfall wohl nicht alleine hinbekommen. Aber damit scheint es, soweit ich bisher sehen kann, zu funktionieren! Vor allem rendert es sehr viel schneller, ein weiterer nicht zu unterschätzender Vorteil!

Ich habe nun eine Karte zumindest einigermaßen nach meinen Vorstellungen rendern können. Wollte ich es besser, müßte ich wohl noch ein oder zwei Tage reinstecken. Komm ich leider jetzt in nächster Zeit nicht dazu. Wenn wieder mehr Zeit ist, will ich es aber auf jeden Fall noch einmal verbessern.

Offline

Board footer

Powered by FluxBB