OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2018-11-12 20:40:57

Jonathan Masur
Member
Registered: 2016-04-23
Posts: 98

Possible glitch in rendering boundary near Swiss/Italian border

I think there's a glitch in rendering near the border between Switzerland and Italy near Lake of Lei. The glitch is present at least in mapnik and humanitarian rendering. Unfortunately we can't easily put screenshots here so I'll try to explain in english as best as I can (this is hard to explain).

There is a rectangular area which is an exclave of the commune of Ferrera, which borders a single Italian commune and the commune of Avers. Everything looks correct in the database, the country border on 3 sides and communal border on the 4th side renders correctly. However there is a rendering of an hypothetical 2nd communal border which lies in diagonal within the rectangle. This border is not here in the database, and the area was not changed recently so this is not leftovers from a previous rendering of the map. So I think the rendering of this border is due to a glitch. I could be wrong.

Offline

#2 2018-11-15 09:43:25

Maarten Deen
Member
Registered: 2010-05-20
Posts: 232

Re: Possible glitch in rendering boundary near Swiss/Italian border

Interesting. It does seem to run from one node to another. It maybe an artefact after a change or an error in the planet files used for rendering or a rendering bug.
I've removed and recreated the lower node. Let's see if that does something.

Offline

#3 2018-11-15 10:31:08

SomeoneElse
Member
Registered: 2010-10-13
Posts: 1,134

Re: Possible glitch in rendering boundary near Swiss/Italian border

Jonathan Masur wrote:

Unfortunately we can't easily put screenshots here

Can you upload a screenshot to an external image hosting site?  I don't think I'm seeing what you're seeing...

Offline

#4 2018-11-15 10:54:16

TZorn
Member
From: Leverkusen
Registered: 2015-06-02
Posts: 676

Re: Possible glitch in rendering boundary near Swiss/Italian border

I see it, too:

ferrerauafiw.jpg

That line does not have any labeling in Humanitarian Layer.

Offline

#5 2018-11-15 11:00:00

Maarten Deen
Member
Registered: 2010-05-20
Posts: 232

Re: Possible glitch in rendering boundary near Swiss/Italian border

There is a diagonal NE-SW border from node 665617373 to node 6062970922

Offline

#6 2018-11-15 11:01:26

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,249
Website

Re: Possible glitch in rendering boundary near Swiss/Italian border

Jonathan Masur wrote:

Unfortunately we can't easily put screenshots here so I'll try to explain in english as best as I can.

Upload your screenshot to a pic hoster (e.g. pic-upload.de), fetch the forum link and post as IMG-Link.

Regards
walter

Offline

#7 2018-11-15 11:26:18

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,249
Website

Re: Possible glitch in rendering boundary near Swiss/Italian border

it's gone (in mapnik)

what have i done?

"Tickled" the boundaries of Avers & Ferrera by sorting the relations (will change relations in osm database) and moved all nodes of https://www.openstreetmap.org/way/122998656 just a very little bit (this will update involved way & nodes).

cs: https://www.openstreetmap.org/changeset/64521824

forced mapnik to render this area asap (/dirty) by https://a.tile.openstreetmap.org/16/344 … .png/dirty

reload browser with SHIFT/F5

regards
walter

Last edited by wambacher (2018-11-15 11:31:27)

Offline

#8 2018-11-21 22:25:40

Jonathan Masur
Member
Registered: 2016-04-23
Posts: 98

Re: Possible glitch in rendering boundary near Swiss/Italian border

OK so the rendering is now fixed, but that doesn't explain how the glitch happened in the first place, does it ?

Offline

Board footer

Powered by FluxBB