OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

Announcement

A fix has been applied to the login system for the forums - if you have trouble logging in please contact support@openstreetmap.org with both your forum username and your OpenStreetMap username so we can make sure your accounts are properly linked.

#1 2017-10-04 13:18:39

michalfabik
Member
Registered: 2016-01-25
Posts: 27

Unwanted behaviour of JOSM's default drawing mode

Hi, 
I'm using the latest stable version of JOSM and whenever I add a node in the default drawing mode (i.e. after pressing 'A'), the editor view centers itself on the last added node. This is somewhat handy (read: not that annoying) when drawing roads that are more or less straight as it reduces the need to move the mouse that much but it really gets in the way when drawing stuff with lots of sharp angles and unevenly spaced nodes. Has anybody any idea how to turn it off? I'm not quite sure if it's behaving like this since the last update or if I've turned it on by pressing something by accident. I've googled around but I the only somewhat relevant thing that I've found is the documentation of the FastDraw plugin which I don't even have installed.
Many thanks.

Offline

#2 2017-10-04 14:33:42

PHerison
Member
From: Oberursel, Germany
Registered: 2008-04-04
Posts: 1,279

Re: Unwanted behaviour of JOSM's default drawing mode

Try Ctrl+Shift+F to toggle mode on and off:

https://josm.openstreetmap.de/wiki/Shortcuts --> Viewport

Last edited by PHerison (2017-10-04 14:35:25)

Offline

#3 2017-10-04 17:43:25

Klumbumbus
Member
Registered: 2014-01-12
Posts: 471
Website

Re: Unwanted behaviour of JOSM's default drawing mode

It is called "Viewport Following" and you can find it in the View menu too (Expert mode only).

Offline

#4 2017-10-05 18:27:04

michalfabik
Member
Registered: 2016-01-25
Posts: 27

Re: Unwanted behaviour of JOSM's default drawing mode

Thanks so much, that did it. 
 
(How do I mark the thread as solved?)

Offline

#5 2017-10-05 19:07:18

n76
Member
Registered: 2013-05-22
Posts: 169

Re: Unwanted behaviour of JOSM's default drawing mode

michalfabik wrote:

Thanks so much, that did it. 
 
(How do I mark the thread as solved?)

I wouldn't bother, but I suspect that since you started the thread you might be able to edit the thread title. If not, then I guess it will take a moderator to do it.

View point following is a mode that I used to accidentally get into from time to time (I hate it with a passion). And since it is an accidental finger slip that gets me there I had no clue on how to get out of it. . . So I went searching the web yet again looking for a thread like this to remind me.

I finally figured out that I could go into the preferences and in the keyboard shortcuts area disable that wretched key combination.

Offline

#6 2017-10-05 20:51:28

Klumbumbus
Member
Registered: 2014-01-12
Posts: 471
Website

Re: Unwanted behaviour of JOSM's default drawing mode

you can change the thread title by editing your first comment

Offline

Board footer

Powered by FluxBB