OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

Announcement

A fix has been applied to the login system for the forums - if you have trouble logging in please contact support@openstreetmap.org with both your forum username and your OpenStreetMap username so we can make sure your accounts are properly linked.

#1 2017-01-15 18:07:00

glglgl
Member
Registered: 2014-06-19
Posts: 122

JOSM doesn't work in the newest versions

Hi,

until some months ago, I could work with JOSM without any problems. The last version working correctly at my PC (running under OpenSuSE 13.1 and Gnome) is 10526.

Under 11427, I literally cannot do anything any longer.

If I try to download data, I get a java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.MapView$LayerChangeListener. The same happens if I open a file for editing.

It seems to be such a fundamental error that I think it is probably related to my local installation rather than anything else.

At work – where I use Windows – everything works as it should.

Before raising a ticket, I'd like to ask here: What do I do wrong resp. what can I do?

Last edited by glglgl (2017-01-15 18:07:44)


glglgl

Offline

#2 2017-01-15 18:19:47

mmd
Member
Registered: 2010-11-06
Posts: 1,138

Re: JOSM doesn't work in the newest versions

That's probably some outdated Plugin. Check this post: https://forum.openstreetmap.org/viewtop … 64#p624064

(Translation: Rename plugin directory and try again)

Last edited by mmd (2017-01-15 18:21:39)


Overpass API by Example - mit vielen neuen Beispielen für Version 0.7.54!

Offline

Board footer

Powered by FluxBB