You are not logged in.

Announcement

*** NOTICE: forum.openstreetmap.org is being retired. Please request a category for your community in the new ones as soon as possible using this process, which will allow you to propose your community moderators.
Please create new topics on the new site at community.openstreetmap.org. We expect the migration of data will take a few weeks, you can follow its progress here.***

#1 2014-02-19 14:52:47

keic
Member
Registered: 2014-02-19
Posts: 2

Gmap.net

Hi,
Im using gmap.net control with the openstreetmap provider.
The problem is that when i pass HttpWebRequest from the following url :
http://nominatim.openstreetmap.org/reve … sdetails=1
(retrieving placemark info)
i get response from the server error 403 unathorized acces.
What is strange becaous when in the same instance of the application i pass HttpWebRequest :
http://nominatim.openstreetmap.org/sear … format=xml i get correct results with no errors.
Credentials = {"greatmaps", "greatmaps"}.
When i type them both in the opera i get correct info in the xml file.
What needs to be done to pass correct request for openstreetmap ?
Thanks for help.

Offline

#2 2014-02-19 17:43:52

Pieren
Member
Registered: 2007-10-31
Posts: 312

Re: Gmap.net

Your first link works for me. Perhaps it was a temporary breakdown...

Offline

#3 2014-02-19 18:25:24

keic
Member
Registered: 2014-02-19
Posts: 2

Re: Gmap.net

It works but not in the code. When i use Gmap.net (can be Gmap.net problem specific) but i don't see any diffrence except it's reverse query.
Only query with keyword works. HttpWebRequest is System.Net.HttpWebRequest.

Offline

#4 2014-02-26 11:29:14

smallint
Member
Registered: 2014-02-25
Posts: 2

Re: Gmap.net

Just checked the first url with WizTools.org RESTClient 2.4 which worked as GET as well as POST...
You getting 403 is strange indeed. maybe, there is a (Gmap.net specific?) proxy between you and nominatim.openstreetmap.org

Offline

Board footer

Powered by FluxBB