OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2009-01-09 09:45:20

Mubashar Ehsan
Member
Registered: 2009-01-09
Posts: 1

Standalone potlatch configuration problem

I have followed all mentioned steps in http://wiki.openstreetmap.org/wiki/Potl … _compiling and installed potlatch, and after that compiled potlatch.swf file into my web server directory but now i got a page having a message "Please wait. Loading presets..." and a triangle with caution sign blinking at left bottom of the page. Can anybody guide me how can i get rid from this message and get OSM map working?

Offline

#2 2009-01-09 13:08:40

Richard
Member
From: Charlbury, UK
Registered: 2007-04-24
Posts: 364
Website

Re: Standalone potlatch configuration problem

The version of Potlatch in svn is designed to work against the 0.6 API, not the current (production) 0.5 API. You'll need to run the version of the site from /sites/rails_port_branches/api06/ to work.

Alternatively, you can get the previous, 0.5-friendly version of Potlatch by checking out revision 11469 of /applications/editors/potlatch/ .

Sorry for the hassle - I didn't anticipate API 0.6 was going to take so long to finish, I'd have created a branch if so.

Offline

Board footer

Powered by FluxBB