You are not logged in.

#26 2013-07-12 09:21:52

Osmonav
Member
Registered: 2013-05-19
Posts: 33

Re: Hilfe bei Postgis Einrichtung

Lübeck wrote:

psql:legacy.sql:770: HINWEIS:  Argumenttyp geometry ist nur eine Hülle
psql:legacy.sql:770: FEHLER:  Typ spheroid existiert nicht

Möglicherweise postgis nicht korrekt installiert?

Lübeck wrote:

SELECT AddGeometryColumn

Das ist nicht falsch, aber afaik ab postgis 2 nicht mehr notwendig. Geometry-Columns können genauso wie alle anderen Datentypen erzeugt werden.

Lübeck wrote:

Die Tags sind alle in der gleichnamigen Spalte hinterlegt.

Das dürfte der hstore sein. Es ist sinnvoller, sich später die Spalten zu machen, die man dann wirklich braucht. Die paar Standardspalten lohnen den Aufwand nicht, den Gedankengängen der vorgefertigten Skripte folgen zu müssen. Bei mir habe ich alleine für Linien 85 Spalten. Vielleich käme ich mit 10% weniger aus, aber irgendwas braucht man immer für irgendeine Logig.

Lübeck wrote:

Dann eine Frage zum allgmeinen. Wenn man dann mal ein Projekt im Süden, im Norden und Westen hat und diese relativ räumlich begrenzt sind würde man diese Daten in eine DB aufnehmen oder zur jedes eine eigene DB?

Das kommt darauf an, was du machen willst. Wenn du Pläne in verschiedenen Maßstäben machen willst, die voneinander unabhängig sind, sich teilweise sogar noch überlappen könnten, dann mache ich für jede Karte eine DB. Wenn du eine weltweite Karte online stellen oder sonstige Auswertungen fahren willst, ohne irgendwelche Daten manipulieren zu müssen, kommt es wieder auf deinen Platz, die Rechenkapazität und das Gebiet an. Ständige Auswertungen für ein einigermaßen zusammenhängendes Gebiet sind natürlich mit einer einzigen, ständig aktuell gehaltenen DB sinnvoller.

Lübeck wrote:

Zu guter Letzt das Thema Update. Kommen neue Daten - ich spreche jetzt nicht von einem Intervall-Update ! - dann müßte man pgsnapshot_schema_0.6.sql nur neu einlesen und alles ist für diese DB zurückgesetzt ! Korrekt ?

Installiere deine DB erst einmal sauber. Dann sieh dir den Prozess an und vollziehe es nach. Das ist sowieso wichtig, weil du früher oder später das noch einmal machen musst, spätestens auf einer neuen Platte/Rechner. Wenn das ganze reibungslos läuft, erstelle dir ein Script, das das Ganze automatisch erledigen kann. In den Punkt solltest du ruhig Arbeit stecken, davon lebst du später. Das Script vervollständigst du dann im Verlauf der weiteren Bearbeitung Schritt für Schritt. Dann kannst du jederzeit deine DB wegschmeißen und neu aufbauen, falls du nicht gerade ganz Europa laden willst. Während die Kiste läuft, holst du dir einen Kaffee und kannst dann weiter machen ;-). Wenn du die DB nicht löschst, sondern nur die Tabellen, kannst du qgis sogar weiterlaufen lassen. Natürlich nicht gerade dann zoomen oder sowas ;-) Dann kannst du auch Daten, die nicht gelöscht werden sollen, in einer extra-Tabelle aufheben, die erhalten bleibt und anschließend ggf. wieder eingepflegt wird.

Versionskonflikte gibt es dabei gar nicht. Falls wirklich postgres mit einer neuen Version eingespielt wird, prüfst du dein Script mit der neuen Version, haust die alten DBs weg und erzeugst sie, soweit gebraucht, neu. Erhaltenswerte Tabellen müssten dann mit pgdump vorher gesichert werden, aber das sollte das Script automatisch sowieso machen. Außerdem ist das ggf. auch eine Frage der Datensicherung.

Die einzigen Versionskonflikte, die wirklich ärgerlich sind, entstehen bei neuen Versionen von qgis. Der kann teilweise sein Konfig-file aus der vorhergehenden Version nicht korrekt lesen.

Wie gesagt, wenn du die ganze Welt mit allen Daten ständig aktuell vorhalten willst, sieht das natürlich anders aus.

Gruß, Wolfgang

Offline

#27 2013-07-12 09:33:43

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Moin !

das sieht wohl nicht gut aus :-(

psql_20130712a.jpg

Ich hatte das in die Console unter Plugins>PSQL Console eingegeben!

Gruß Jan :-)

PS: habe nochmal gegoggeld und unter https://www.pg-forum.de/viewtopic.php?t=4565 einen Beitrag von dem akretschmer gefunden:

Das glaub ich Dir sogar - und vermute, Du hast PostGIS einfach nur auf der falschen Datenbank installiert, und nicht auf der, wo Du arbeitest...

Kann das bei mir auch der Fehler sein ? Wie könnte ich das prüfen?

Hier noch mein Strukturbaum

psql_20130712b.jpg

Gruß Jan :-)

Last edited by Lübeck (2013-07-12 09:37:16)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#28 2013-07-12 09:38:09

Osmonav
Member
Registered: 2013-05-19
Posts: 33

Re: Hilfe bei Postgis Einrichtung

Prüfe den Installtionsweg, besonders postgis. Ich habe nicht den Eindruck, dass es funzt.

Gruß, Wolfgang

Offline

#29 2013-07-12 09:43:47

Osmonav
Member
Registered: 2013-05-19
Posts: 33

Re: Hilfe bei Postgis Einrichtung

Lübeck wrote:

Kann das bei mir auch der Fehler sein ? Wie könnte ich das prüfen?

Eben erste gesehen...

Ja, das ist wahrscheinlich der Fehler.

        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis_comments.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/spatial_ref_sys.sql
        psql -d "$DATENBANK" -c "create extension hstore;"

wird unter Windows wohl etwas anders heißen.

Das ist der Nachteil bei den Scripten: Man installiert dauernd und kennt die Einzelheiten nicht mehr;-)

Gruß, Wolfgang

Offline

#30 2013-07-12 09:49:15

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Hallo Wolfgang,

ich mir derzeit nicht mehr sicher die 3-SQL eingebunden zu haben !?!??!?

Habe nochmal nachgesehen und unter http://wiki.openstreetmap.org/wiki/Osmo … stgres_9.1 wird bei 9.1. nicht mehr davon geschrieben.

Dann muss ich die wohl nochmal nachschießen !!

Gruß Jan :-)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#31 2013-07-12 09:59:15

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,695
Website

Re: Hilfe bei Postgis Einrichtung

Lübeck wrote:

Moin !

das sieht wohl nicht gut aus :-(

http://www.tappenbeck.net/forum/osm/psql_20130712a.jpg

Stimmt! Da sind viel zu wenige Funktionen drin. Du hast 216 und ich habe 1350 - siehe meinen 1 screenshot aus post #20. Ca 20 sind von mir also sollten es etwa 1330 sein.

--> PostGis nicht richtig installiert.

Gruss
walter

Offline

#32 2013-07-12 10:00:28

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,695
Website

Re: Hilfe bei Postgis Einrichtung

Osmonav wrote:

Ja, das ist wahrscheinlich der Fehler.

        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis_comments.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/spatial_ref_sys.sql
        psql -d "$DATENBANK" -c "create extension hstore;"

wird unter Windows wohl etwas anders heißen.

Könnte was dran sein wink

Offline

#33 2013-07-12 10:02:46

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Hi !

ist da was von wegen Reihenfolge wichtig ?

Gruß Jan :-)

PS: habe nicht gewartet und habe die 3 SQL eingebunden..

psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/postgis_comments.sql
        psql -d "$DATENBANK" -f /usr/share/postgresql91/contrib/postgis-2.0/spatial_ref_sys.sql

Es gab keine Fehlermeldungen und aus 216 Funktionen sind jetzt schon einmal 741 geworden.

@wambacher: zu #25 - jetzt gibt es folgende Rückmeldungen....

psql_20130712c.jpg

und

psql_20130712d.jpg

looks better ?

Last edited by Lübeck (2013-07-12 10:51:46)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#34 2013-07-12 14:26:42

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

hi !

ich habe jetzt einfach mal wieder Mut zur Lücke gehabt und den osmosis-Import in Betrieb genommen - dabei ist folgendes herausgekommen:

D:\GIS\PostgreSQL>d:\DATEN\Jan\openstreetmap/osmosis/bin/osmosis.bat --read-xml
file="innenstadt.osm" --write-pgsimp user="postgres" database="osm" password="os
m"
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.Osmosis run
INFO: Osmosis Version 0.43.1
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.Osmosis run
INFO: Preparing pipeline.
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.Osmosis run
INFO: Launching pipeline execution.
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.Osmosis run
INFO: Pipeline executing, waiting for completion.
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.pipeline.common.ActiveTaskMan
ager waitForCompletion
SCHWERWIEGEND: Thread for task 1-read-xml failed
org.openstreetmap.osmosis.core.OsmosisRuntimeException: The database schema vers
ion of 6 does not match the expected version of 5.
        at org.openstreetmap.osmosis.pgsimple.common.SchemaVersionValidator.vali
dateDBVersion(SchemaVersionValidator.java:80)
        at org.openstreetmap.osmosis.pgsimple.common.SchemaVersionValidator.vali
dateVersion(SchemaVersionValidator.java:50)
        at org.openstreetmap.osmosis.pgsimple.v0_6.PostgreSqlWriter.initialize(P
ostgreSqlWriter.java:183)
        at org.openstreetmap.osmosis.pgsimple.v0_6.PostgreSqlWriter.process(Post
greSqlWriter.java:773)
        at org.openstreetmap.osmosis.xml.v0_6.impl.BoundsElementProcessor.end(Bo
undsElementProcessor.java:84)
        at org.openstreetmap.osmosis.xml.v0_6.impl.OsmHandler.endElement(OsmHand
ler.java:107)
        at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source
)
        at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unkn
own Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElemen
t(Unknown Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContent
Dispatcher.dispatch(Unknown Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Un
known Source)
        at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
        at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
        at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
        at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Sour
ce)
        at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
        at javax.xml.parsers.SAXParser.parse(Unknown Source)
        at org.openstreetmap.osmosis.xml.v0_6.XmlReader.run(XmlReader.java:111)
        at java.lang.Thread.run(Unknown Source)
12.07.2013 15:22:27 org.openstreetmap.osmosis.core.Osmosis main
SCHWERWIEGEND: Execution aborted.
org.openstreetmap.osmosis.core.OsmosisRuntimeException: One or more tasks failed
.
        at org.openstreetmap.osmosis.core.pipeline.common.Pipeline.waitForComple
tion(Pipeline.java:146)
        at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:92)
        at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:37)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Laun
cher.java:329)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav
a:239)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La
uncher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:
352)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:47)

An den abweichenden Richtungen des osmosis-Aufrufs kann es nicht gelegen haben. Vielmehr ist es die Zeile

SCHWERWIEGEND: Thread for task 1-read-xml failed
org.openstreetmap.osmosis.core.OsmosisRuntimeException: The database schema vers
ion of 6 does not match the expected version of 5.

Wenn ich das richtig gesehen habe, dann hat meine DB das Schema 0.6 - wie kommt osmsis dann auf den Gedanken das Schema 0.5 anwenden und kann man das zuweisen ?? Das DB-Schema stammt doch aus dem osmosis-Verzeichnis .... ?

Gruß Jan :-)

Last edited by Lübeck (2013-07-12 14:52:05)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#35 2013-07-12 16:17:21

Osmonav
Member
Registered: 2013-05-19
Posts: 33

Re: Hilfe bei Postgis Einrichtung

Hallo Jan,

könnte es sein, dass der Fehler das Einlesen der osm-Datei betrifft?

Hast du möglicherweise osm-Daten ohne user und Datum runtergeladen?

Oder eine veraltete osmosis-Version?

0.6 ist die aktuelle api von osm.

Gruß, Wolfgang

Offline

#36 2013-07-12 16:32:54

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,695
Website

Re: Hilfe bei Postgis Einrichtung

Lübeck wrote:

Wenn ich das richtig gesehen habe, dann hat meine DB das Schema 0.6 - wie kommt osmsis dann auf den Gedanken das Schema 0.5 anwenden und kann man das zuweisen ?? Das DB-Schema stammt doch aus dem osmosis-Verzeichnis .... ?

Klaro:
Willst du das Snapshot-Schema verwenden, dann mußt du das auch richtig angeben, that's all.

D:\GIS\PostgreSQL>d:\DATEN\Jan\openstreetmap/osmosis/bin/osmosis.bat --read-xml
file="innenstadt.osm" --write-pgsql user="postgres" database="osm"...

Ich brauche noch die Details von WAYS - du hast mir nodes aufgelistet. Es geht darum ob linestring und bbox als Spalten vorhanden sind. Die entsprechende Frage hast du noch nicht beantwortet.

Gruss
walter

Last edited by wambacher (2013-07-12 16:33:30)

Offline

#37 2013-07-12 17:51:16

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Danke !

Versuche jetzt WE zu machen. Aber gute nachvollziehbare Ansätze.

Gruß Jan


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#38 2013-07-15 09:24:22

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Moin !

so jetzt werde ich diese Fragen mal abarbeiten.

@Omsonav: hattest recht

<node id='-8004' action='modify' visible='true' lat='53.871157563214744' lon='10.686274338069497'>

Werde mal Daten von Schleswig-Holstein von der Geofabrik ziehen und versuchen zu importieren.

Melde mich wieder ....

Gruß Jan :-)

War schneller fertig als erwartet - aber loggt immer noch einen Fehler:

D:\GIS\PostgreSQL>d:\DATEN\Jan\openstreetmap/osmosis/bin/osmosis.bat --read-xml
file="schleswig-holstein-latest.osm.bz2" --write-pgsql user="postgres" database=
"osm" password="osm"
15.07.2013 10:25:16 org.openstreetmap.osmosis.core.Osmosis run
INFO: Osmosis Version 0.43.1
15.07.2013 10:25:16 org.openstreetmap.osmosis.core.Osmosis run
INFO: Preparing pipeline.
15.07.2013 10:25:16 org.openstreetmap.osmosis.core.Osmosis run
INFO: Launching pipeline execution.
15.07.2013 10:25:16 org.openstreetmap.osmosis.core.Osmosis run
INFO: Pipeline executing, waiting for completion.
15.07.2013 10:28:00 org.openstreetmap.osmosis.core.pipeline.common.ActiveTaskMan
ager waitForCompletion
SCHWERWIEGEND: Thread for task 1-read-xml failed
org.springframework.jdbc.BadSqlGrammarException: StatementCallback; bad SQL gram
mar [DROP INDEX idx_nodes_geom]; nested exception is org.postgresql.util.PSQLExc
eption: FEHLER: Index ╗idx_nodes_geom½ existiert nicht
        at org.springframework.jdbc.support.SQLStateSQLExceptionTranslator.doTra
nslate(SQLStateSQLExceptionTranslator.java:98)
        at org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslat
or.translate(AbstractFallbackSQLExceptionTranslator.java:72)
        at org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslat
or.translate(AbstractFallbackSQLExceptionTranslator.java:80)
        at org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslat
or.translate(AbstractFallbackSQLExceptionTranslator.java:80)
        at org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:
407)
        at org.springframework.jdbc.core.JdbcTemplate.update(JdbcTemplate.java:5
19)
        at org.openstreetmap.osmosis.pgsnapshot.v0_6.impl.IndexManager.prepareFo
rLoad(IndexManager.java:103)
        at org.openstreetmap.osmosis.pgsnapshot.v0_6.impl.CopyFilesetLoader.run(
CopyFilesetLoader.java:92)
        at org.openstreetmap.osmosis.pgsnapshot.v0_6.PostgreSqlCopyWriter.comple
te(PostgreSqlCopyWriter.java:123)
        at org.openstreetmap.osmosis.xml.v0_6.XmlReader.run(XmlReader.java:113)
        at java.lang.Thread.run(Unknown Source)
Caused by: org.postgresql.util.PSQLException: FEHLER: Index ╗idx_nodes_geom½ exi
stiert nicht
        at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryEx
ecutorImpl.java:2103)
        at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutor
Impl.java:1836)
        at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.ja
va:257)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Stat
ement.java:512)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(Abstract
Jdbc2Statement.java:374)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdb
c2Statement.java:302)
        at org.apache.commons.dbcp.DelegatingStatement.executeUpdate(DelegatingS
tatement.java:228)
        at org.apache.commons.dbcp.DelegatingStatement.executeUpdate(DelegatingS
tatement.java:228)
        at org.springframework.jdbc.core.JdbcTemplate$1UpdateStatementCallback.d
oInStatement(JdbcTemplate.java:509)
        at org.springframework.jdbc.core.JdbcTemplate$1UpdateStatementCallback.d
oInStatement(JdbcTemplate.java:1)
        at org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:
396)
        ... 6 more
15.07.2013 10:28:00 org.openstreetmap.osmosis.core.Osmosis main
SCHWERWIEGEND: Execution aborted.
org.openstreetmap.osmosis.core.OsmosisRuntimeException: One or more tasks failed
.
        at org.openstreetmap.osmosis.core.pipeline.common.Pipeline.waitForComple
tion(Pipeline.java:146)
        at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:92)
        at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:37)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Laun
cher.java:329)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav
a:239)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La
uncher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:
352)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:47)

D:\GIS\PostgreSQL>

Hier noch die Testabfragen

jt_psql_nodes_20130715.jpg
jt_psql_ways_20130715.jpg
jt_psql_relations_20130715.jpg

ist das so ok ?

Wenn ich

SELECT * FROM nodes;

Absetze ist das Ausgabefeld leider leer - also muss ja noch etwas falsch gelaufen sein ??

Gruß Jan

Last edited by Lübeck (2013-07-15 09:43:49)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#39 2013-07-15 10:22:20

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,695
Website

Re: Hilfe bei Postgis Einrichtung

Hier steht, was dir noch fehlt: http://forum.openstreetmap.org/viewtopi … 59#p346759  bbox & linestring bei ways + die passenden indices bei nodes und ways. relations sieht sauber aus.

Achtung: die beiden Scripte GENAU in der Reihenfolge laden, wie es in der Doku steht.

Da du pgsnapshot_load_0.6.sql offensichtlich nicht verwendest, mußt du zumindest die Befehle zum Erzeugen der Indices laufen lassen.

Nachher muss ways so aussehen:

                  Table "public.ways"
    Column    |            Type             | Modifiers 
--------------+-----------------------------+-----------
 id           | bigint                      | not null
 version      | integer                     | not null
 user_id      | integer                     | not null
 tstamp       | timestamp without time zone | not null
 changeset_id | bigint                      | not null
 tags         | hstore                      | 
 nodes        | bigint[]                    | 
 bbox         | geometry(Geometry,4326)     | 
 linestring   | geometry(Geometry,4326)     | 
Indexes:
    "pk_ways" PRIMARY KEY, btree (id)
    "idx_ways_bbox" gist (bbox)
    "idx_ways_linestring" gist (linestring) CLUSTER

also bbox VOR linestring, sonst knallt es beim Import, den du eh neu machen musst.

und nodes:

                  Table "public.nodes"
    Column    |            Type             | Modifiers 
--------------+-----------------------------+-----------
 id           | bigint                      | not null
 version      | integer                     | not null
 user_id      | integer                     | not null
 tstamp       | timestamp without time zone | not null
 changeset_id | bigint                      | not null
 tags         | hstore                      | 
 geom         | geometry(Point,4326)        | 
Indexes:
    "pk_nodes" PRIMARY KEY, btree (id)
    "idx_nodes_geom" gist (geom)

Inzwischen ist die Lage bei dir ziemlich konfus und es ist schwer, Bedienungsfehler zu erkennen. Zumindest sehe ich, dass bis jetzt einiges fehlt. (Spalten und Indices).

Gruss
walter

Last edited by wambacher (2013-07-15 10:24:11)

Offline

#40 2013-07-15 10:38:26

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Moin!

beide SQL sind in GENAU der Reihenfolge eingelaufen! Leider funktioniert das bei mir (Windows?) mit der Kurzschreibweise nicht! Hatte das wohl in dem anderen Posting irgendwie übersehen.

jt_psql_2sql_20130715.jpg

mußt du zumindest die Befehle zum Erzeugen der Indices laufen lassen.

... was meinst Du damit - noch ein anderes spezielles Kommando oder Script ??

Anm.: Parallel schreibe ich schon ein Installationsprotokoll - dann kann man es später in einem Stück nochmal nachvollziehen ....

Gruß Jan :-)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#41 2013-07-16 11:47:58

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

Moin !

so - heute morgen habe ich die DB nochmal gelöscht und nach meiner Zusammenfassung

http://wiki.openstreetmap.org/wiki/User … QL-Scripte

alles Schritte nochmal nacheinander durchgeführt und dann hat auch osmosis gearbeitet OHNE etwas zu beanstanden.

Hier dann nochmal die abschließenden "\d-Test":

jt_psql_20130716.jpg

Wenn es das gewesen sein soll, dann danke ich bisher erst einmal allen die soviel Geduld mit mir an dieser Stelle hatten.

Bis zum nächsten Mal .-)

Gruß Jan :-)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

#42 2013-07-16 12:31:18

wambacher
Member
From: Schlangenbad/Wambach, Germany
Registered: 2009-12-16
Posts: 16,695
Website

Re: Hilfe bei Postgis Einrichtung

Lübeck wrote:

Wenn es das gewesen sein soll, dann danke ich bisher erst einmal allen die soviel Geduld mit mir an dieser Stelle hatten.

Prima Entschluss, die ganze Sache nochmals neu zu machen.

Irgendwo ist irgendwann irgendwas irgendwie komisch gelaufen - Schwamm drüber.

Gratulation
walter

p.s. ich hab damals - kurz nach dem Ardennenfeldzug - auch mehrere Tage gebraucht, bis meine erste DB rund lief.

Offline

#43 2013-07-16 14:39:36

Lübeck
Member
Registered: 2009-02-17
Posts: 2,837

Re: Hilfe bei Postgis Einrichtung

... das ist nicht das Ende ....!

-> http://forum.openstreetmap.org/viewtopi … 69#p347569

mit einer Datenverbindung zu qgis !

Gruß Jan :-)


PS: wie http://forum.openstreetmap.org/viewtopic.php?pid=347595 war die DB-Installation doch noch nicht ganz fertig .... vielleicht liest einer von Euch dort noch etwas mit.

Würde mich sehr freuen - war schon so euphorisch !

Last edited by Lübeck (2013-07-16 15:33:05)


Redmi Note 9 Pro  mit Android 11, Tablet Android 8.1, PC: Win10

Offline

Board footer

Powered by FluxBB