You are not logged in.

#1 2011-04-04 05:45:28

T99
Member
Registered: 2010-06-27
Posts: 22

JOSM tagging presets

I have used "Better presets for Ways" (http://openmtbmap.x-nation.de/josm/adva … ghways.xml) just because it claims to be "better".  Unfortunatly, the site has vanished so I haven't had any presets for a while.

The "Reset" button reverted my preferences to "Internal Preset" (resource://data/defaultpresets.xml).  However, this setting does not produce any working presets either.  I can't figure out where this "resource" location is supposed to be -- there is no "data" folder under my C:\JOSM.

Questions:

1. Where can I find a working set of presets for higways etc?

2. After I customize these presets, how can I tell JOSM to use the file on a local disk?  (Would something like file://C:\JOSM\mypresets.xml work?)

Offline

#2 2011-04-04 06:03:32

T99
Member
Registered: 2010-06-27
Posts: 22

Re: JOSM tagging presets

Responding to my own question: I found the default preset file at:
http://josm.openstreetmap.de/svn/trunk/ … resets.xml

Finally I can have tunnels with default layer -1 and one-click unnamed secondary_link highways with oneway=yes.  Nothing is "better" than that!

Offline

#3 2011-04-04 07:05:59

T99
Member
Registered: 2010-06-27
Posts: 22

Re: JOSM tagging presets

Btw, I found out why the presents had disappeared:

- The "Presets" menu option is always grayed out when there JOSM has just started and there are no data layers (this seems odd).

- The toolbar buttons for preset folders had disappeared when the "better" preset site vanished, and I had to redefine them manually (the end result is better than the original, of course).

I also found out that the "better" presets were not so good; the standard presets are more complete (only highway=secondary_link was missing).

Offline

Board footer

Powered by FluxBB