OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2012-06-05 11:01:41

denzil
Member
From: West Cornwall, UK
Registered: 2010-04-25
Posts: 15

JOSM imagery not working

I am using the latest JOSM (5267), but have been seeing this for the last several versions. I run Linux Mint 9, if it makes a difference.

The imagery layers don't work properly. If I try to show an OS Open Data layer, for example, it displays a completely different and unidentifiable piece of map, at the wrong scale and repeated tile fashion. I'll do a screenshot if it will help. Is this a known problem? I have had a look through the JOSM active tickets, but can't find anything similar.

Offline

#2 2012-06-05 13:27:13

Re: JOSM imagery not working

Please open a new ticket and write a bug report.

Offline

#3 2012-08-11 23:16:09

denzil
Member
From: West Cornwall, UK
Registered: 2010-04-25
Posts: 15

Re: JOSM imagery not working

So, as you have seen, it seems to be specific to this machine, so maybe it is better disciussed here. For others' benefit, I also have a problem with some imagery not displaying correctly. I'm now running JOSM version 5356. I have tested on a laptop also running LM13 and JOSM, and it works fine. The same JRE is used on both machines (openjdk-6-jre). I have tried openjdk-7-jre but the behaviour is the same.

Tried Oracle JRE from instructions here, but get a 404 not found on the repository. Any other ideas?

Offline

#4 2012-09-27 21:25:53

denzil
Member
From: West Cornwall, UK
Registered: 2010-04-25
Posts: 15

Re: JOSM imagery not working

So nobody can help?

Offline

#5 2012-09-27 23:18:23

Vclaw
Senior Member
From: Alba
Registered: 2009-02-25
Posts: 499
Website

Re: JOSM imagery not working

Try deleting your preferences directory? See http://josm.openstreetmap.de/wiki/Help/ResetPreferences

Offline

#6 2012-09-30 11:39:12

denzil
Member
From: West Cornwall, UK
Registered: 2010-04-25
Posts: 15

Re: JOSM imagery not working

Woohoo, that did the trick! Thank you. It is now working normally.

Offline

Board footer

Powered by FluxBB 1.4.8
Hosting sponsored by Oxilion