OpenStreetMap Forum

The Free Wiki World Map

You are not logged in.

#1 2012-11-22 10:05:22

Something went wrong in Sweden

Lambertus,

I just downloaded South-Sweden as part of the OpenFietsmap-lite.

It should look like this:

http://www.openstreetmap.org/?lat=58.85 … 9&layers=M

But in in Mapsource it lookes like this:

Zuid-Zweden.JPG

And in detail:

Zuid-Zweden%20detail.JPG

How come?

Peter

Offline

#2 2012-11-22 10:19:00

Re: Something went wrong in Sweden

Hi Peter,
It has to do with some old problems with the Tile Splitter. They are working on it right now, and the new version solves those problems.
So those floodings will be likely solved soon.

Online

#3 2012-11-22 10:27:41

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

A problem with polygons and how the splitting is handling polygons that cross tileborders. I think I saw some messages on the Mkgmap mailinglist about similar problems, so I'll upgrade the splitter and Mkgmap for the next update and see what happens.

Edit: crossposted with Ligfietser. Thanks Ligfietser!


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#4 2012-11-22 11:25:38

Re: Something went wrong in Sweden

Thanks Lambertus, if you are using the latest mkgmap (2370 or later) I can update my styles for the next update.

Edit: updates committed to svn

Btw for the new splitter you need to add  --keep-complete --overlap=0 to your parameters

Last edited by ligfietser (2012-11-22 11:51:09)

Online

#5 2012-11-22 13:18:27

Re: Something went wrong in Sweden

ligfietser wrote:

So those floodings will be likely solved soon.

It's more a problem that a whole lake is missing (5655 km²). sad

But I will try again in a couple of weeks.

Thank's for the answers.

Peter

Offline

#6 2012-11-22 14:27:34

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

Thanks Ligfietser. I'll try to get an update going tomorrow with updated Mkgmap, Splitter en styles.


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#7 2012-11-24 14:00:11

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

Some may have already read the emails on the Mkgmap mailinglist; the latest development splitter is not capable of splitting the whole world at this point. So I'm using the stable version: r202. But this version does not have the new 'keep polygons complete' functionality. We will have to wait a little longer for the bugs to squashed in the latest version.


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#8 2012-11-24 15:14:06

Re: Something went wrong in Sweden

As temporarily workaround you can set the overlap parameter a little higher (default =2000, maybe 4000 or 5000?) so that larger multipolygons outside the tile are kept complete, but this no guarantee that it works in the Boswachters case.

Online

#9 2012-11-24 23:19:19

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

Possibly, but -as I understand- it requires much more memory. I'll try with the update after this one.


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#10 2012-11-24 23:49:40

Re: Something went wrong in Sweden

I haven't noticed it took too much memory, it went fine on my laptop with only 4GB, only the splitted tiles get a little bigger.
But I think there will be no need to do so looking at the speed of the developments of the splitter  wink

Online

#11 2012-11-27 00:26:35

Re: Something went wrong in Sweden

Does splitter work in Windows? For me Java crashes when I'm trying to split current europe.osm.pbf.
I'm using 64-bit Windows 7, JRE 7.0_09, spliter r202. Maybe I need specific versions of java or specific settings?


popej

Offline

#12 2012-11-27 11:07:00

Re: Something went wrong in Sweden

Yes it should work, try specify the maximum memory with -Xmx

Online

#13 2012-11-28 03:15:52

Re: Something went wrong in Sweden

Thanks for advice but still can't make spliter work with Europe. I have tried Linux and gotten quite similar crash. Could you tell me, what setup are you using to split big files?


popej

Offline

#14 2012-11-28 10:50:04

Re: Something went wrong in Sweden

The command would look like this:

java -Xmx1400m -jar c:\Garmin\mkgmap\splitter-r202\splitter.jar --output-dir=splitter --write-kml=areas.kml --output=pbf --no-trim --max-nodes=1400000 --overlap=3000 --geonames-file=cities5000.txt --description=OSM_EU europe.osm.pbf

You may have to change 1400m depending on your computer, sometimes it needs bigger, sometimes an even smaller amount of memory. I think it is also needed to specify the path where the splitter files are stored, it will not work with splitter.jar alone.

Online

#15 2012-11-28 11:13:46

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

I was quite busy with work deadlines and I didn't check the progress of the new map, so I just saw only now that the openfietsmap render job had not finished yet (has been running since last Friday). This is unusual so I took a look:

Error in style: Error: (points:1): Cannot open included file: inc/address
Could not open style ofm_lite

Ligfietser, I do not see the file named 'address' in the svn repository...


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#16 2012-11-28 11:26:48

Re: Something went wrong in Sweden

Oops, that is my fault, because I'm not familiar with this svn. It did not copy the subdirectory "inc" with the address info when I updated my files.
It should be there now:
http://code.google.com/p/mkgmap-style-s … nc/address

Last edited by ligfietser (2012-11-28 11:28:13)

Online

#17 2012-11-28 12:34:15

Lambertus
Administrator
From: Apeldoorn (NL)
Registered: 2007-03-17
Posts: 3,089
Website

Re: Something went wrong in Sweden

Thanks, updated and a new map-update started smile


Mapping tools: Garmin GPSmap 60CSx, Giant Terrago 2002

Offline

#18 2012-11-28 22:14:01

Re: Something went wrong in Sweden

ligfietser wrote:

The command would look like this:

Thanks again. It is Java 64-bits, that makes problems. Splitter runs correctly when using 32-bits version of Java.


popej

Offline

#19 2012-12-02 00:50:43

Re: Something went wrong in Sweden

@Boswachter: looks like the coast is clear now wink

Online

#20 2012-12-02 12:14:19

Re: Something went wrong in Sweden

Thanks. It is!

But i must confess that you lost me completely in the discussion, but in a way I have the idea that I made a usefull remark. At least I hope I did. big_smile

Peter

Offline

#21 2012-12-02 14:48:48

Re: Something went wrong in Sweden

Of course you did, this was a known mkgmap/splitter problem but thanks to Gerd it looks like it has been solved finally.

Online

Board footer

Powered by FluxBB 1.4.8
Hosting sponsored by Oxilion